summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2023-09-03 10:40:06 +0800
committerLuke from DC <[email protected]>2023-09-03 04:27:00 +0000
commit6fbf55c280e54667fbc7dd615eedee114e6264d1 (patch)
treeb93964e66a27b0ac49ef4bc932c21abe0a9b0e77 /src/meson.build
parent4b078a16e961f2f38478377cfb419b49b5582c1a (diff)
downloadmate-polkit-6fbf55c280e54667fbc7dd615eedee114e6264d1.tar.bz2
mate-polkit-6fbf55c280e54667fbc7dd615eedee114e6264d1.tar.xz
Fix meson build libexecdir to the correct path
Fix https://github.com/mate-desktop/mate-polkit/issues/74
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index 0a56598..63c14e2 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -27,13 +27,13 @@ executable('polkit-mate-authentication-agent-1',
include_directories : config_inc,
c_args : c_args + ['-DPOLKIT_AGENT_I_KNOW_API_IS_SUBJECT_TO_CHANGE'] + ['-DHAVE_CONFIG_H'],
install : true,
- install_dir: get_option('libexecdir')
+ install_dir: libexecdir
)
# .desktop file
desktop_data = configuration_data()
-desktop_data.set('FULL_LIBEXECDIR', get_option('libexecdir'))
+desktop_data.set('FULL_LIBEXECDIR', libexecdir)
desktop_in_file = configure_file(
input : 'polkit-mate-authentication-agent-1.desktop.in.in',
output : 'polkit-mate-authentication-agent-1.desktop.in',