summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-10-27 19:52:28 +0200
committerRobert Antoni Buj Gelonch <[email protected]>2022-01-01 12:00:07 +0100
commit2741b990288cfb82957b79150c4391f29e561df1 (patch)
tree141a951c34c91a686a22ffb2c524ed0e97157831 /configure.ac
parent35c80d8eaa892b3a7d510d791792c554336495e8 (diff)
downloadmate-power-manager-2741b990288cfb82957b79150c4391f29e561df1.tar.bz2
mate-power-manager-2741b990288cfb82957b79150c4391f29e561df1.tar.xz
build: show configure summary using a pretty format
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 16 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 6864dec..ccac6cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -236,19 +236,22 @@ AC_OUTPUT
dnl ==========================================================================
echo "
- MATE Power Manager $VERSION
- =============================
-
- prefix: ${prefix}
- datadir: ${datadir}
- compiler: ${CC}
- cflags: ${CFLAGS}
- cwarnings: ${WARN_CFLAGS}
- libsecret support: ${with_libsecret}
- gnome-keyring support: ${with_keyring}
- Building extra applets: ${enable_applets}
- Self test support: ${have_tests}
- dbus-1 services dir: $DBUS_SERVICES_DIR
+Configure summary:
+
+ ${PACKAGE_STRING}
+ `echo $PACKAGE_STRING | sed "s/./=/g"`
+
+ prefix ......................: ${prefix}
+ datadir .....................: ${datadir}
+ compiler ....................: ${CC}
+ cflags ......................: ${CFLAGS}
+ cwarnings ...................: ${WARN_CFLAGS}
+
+ libsecret support ...........: ${with_libsecret}
+ gnome-keyring support .......: ${with_keyring}
+ Building extra applets ......: ${enable_applets}
+ Self test support ...........: ${have_tests}
+ dbus-1 services dir .........: $DBUS_SERVICES_DIR
"
if [[ "${prefix}" != "/usr" ]] ; then
echo '