summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Brown <[email protected]>2012-11-21 09:15:29 +1030
committerWilliam Brown <[email protected]>2012-11-21 10:14:47 +1030
commit30eed18125a03a0bede7f5e560f8f031db70dcbe (patch)
treeaa39348306cc914825fa0f3c9da0781555329914 /configure.ac
parentc5c3b2a3d755e32a851bf7b3c7ef92a056b5bdef (diff)
downloadmate-power-manager-30eed18125a03a0bede7f5e560f8f031db70dcbe.tar.bz2
mate-power-manager-30eed18125a03a0bede7f5e560f8f031db70dcbe.tar.xz
Adds a systemdinhibit configure flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 312f220..6e36106 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,6 +270,25 @@ AC_MSG_RESULT([$have_applets])
AM_CONDITIONAL([HAVE_APPLETS], [test $have_applets = yes])
dnl ---------------------------------------------------------------------------
+dnl systemd inhibit
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH(systemdinhibit,
+ AS_HELP_STRING([--with-systemdinhibit],
+ [Add systemdinhibit support]),,
+ with_systemdinhibit=auto)
+
+use_systemdinhibit=no
+if test "x$with_systemdinhibit" != "xno" ; then
+ use_systemdinhibit=yes
+ AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
+
+ PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login libsystemd-daemon)
+fi
+AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
+AC_SUBST(WITH_SYSTEMD_INHIBIT)
+
+dnl ---------------------------------------------------------------------------
dnl - DocBook Documentation
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(docbook-docs,
@@ -382,6 +401,7 @@ echo "
Building extra applets: ${enable_applets}
Self test support: ${have_tests}
Use libunique: ${enable_libunique}
+ systemd support: ${use_systemdinhibit}
Docbook support: ${enable_docbook_docs}
documentation dir: $DOCDIR
dbus-1 services dir: $DBUS_SERVICES_DIR