summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Brown <[email protected]>2012-11-29 11:09:31 +1030
committerWilliam Brown <[email protected]>2012-11-29 11:09:31 +1030
commita324df9170a50ca91f9b931f4e9fc5fe916a8c86 (patch)
tree32c97876c27ed9af2e473eacf702830bf40949e6 /configure.ac
parenta9c127a8a3420ac5613a41de212906e4ab90156c (diff)
downloadmate-power-manager-a324df9170a50ca91f9b931f4e9fc5fe916a8c86.tar.bz2
mate-power-manager-a324df9170a50ca91f9b931f4e9fc5fe916a8c86.tar.xz
Added systemd version check, so that we dont catch people who dont need inhibit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c3e60c..e15db51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,7 +280,7 @@ AC_ARG_WITH(systemdinhibit,
use_systemdinhibit=no
if test "x$with_systemdinhibit" != "xno" ; then
- PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login libsystemd-daemon, use_systemdinhibit=yes, use_systemdinhibit=no)
+ PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login >= 195 libsystemd-daemon >= 195 , use_systemdinhibit=yes, use_systemdinhibit=no)
if test "x$use_systemdinhibit" = "xyes"; then
AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])