summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-30 11:50:07 +0800
committerraveit65 <[email protected]>2019-11-12 11:18:15 +0100
commit4b6d373147649c13d6ea625c31f15a34ced324e3 (patch)
tree0215b3594255d27ee81f1fd996ab22564b95b935 /data/Makefile.am
parenta9ff56c6de34f8d3db48f3405c5ee671dc281194 (diff)
downloadmate-power-manager-4b6d373147649c13d6ea625c31f15a34ced324e3.tar.bz2
mate-power-manager-4b6d373147649c13d6ea625c31f15a34ced324e3.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 436cdf7..1092440 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,16 +1,18 @@
SUBDIRS = icons
-@INTLTOOL_DESKTOP_RULE@
desktopdir = $(datadir)/applications
desktop_in_files = mate-power-preferences.desktop.in \
mate-power-statistics.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+$(desktop_DATA): $(desktop_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
-@INTLTOOL_DESKTOP_RULE@
autostartdir = $(sysconfdir)/xdg/autostart
autostart_in_files = mate-power-manager.desktop.in
autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+$(autostart_DATA): $(autostart_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
servicedir = $(DBUS_SERVICES_DIR)
service_in_files = org.mate.PowerManager.service.in
@@ -20,7 +22,6 @@ $(service_DATA): $(service_in_files) Makefile
@sed -e "s|\@servicedir\@|$(bindir)|" $< > $@
@GSETTINGS_RULES@
-@INTLTOOL_XML_NOMERGE_RULE@
gsettings_schemas_in_files = org.mate.power-manager.gschema.xml.in
gsettings_SCHEMAS = $(gsettings_schemas_in_files:.xml.in=.xml)