summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorBrent Hull <[email protected]>2012-10-27 23:04:21 -0400
committerBrent Hull <[email protected]>2012-10-27 23:04:21 -0400
commite58350ab1a00d55e82f7ae97589562e10a77c485 (patch)
treea0a6596880e7305d8403de503653f89e19d313a3 /data/Makefile.am
parentaa88be1d4a4e545b4141b0065b094d49d3d3a81b (diff)
downloadmate-power-manager-e58350ab1a00d55e82f7ae97589562e10a77c485.tar.bz2
mate-power-manager-e58350ab1a00d55e82f7ae97589562e10a77c485.tar.xz
Port to Gsettings based on GNOME patch by Richard Hughes
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am27
1 files changed, 6 insertions, 21 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 80b8a49..0f0d775 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,9 +1,5 @@
SUBDIRS = icons
-@INTLTOOL_SCHEMAS_RULE@
-schemadir = $(sysconfdir)/mateconf/schemas
-schema_in_files = mate-power-manager.schemas.in
-schema_DATA = $(schema_in_files:.schemas.in=.schemas)
@INTLTOOL_DESKTOP_RULE@
desktopdir = $(datadir)/applications
@@ -23,6 +19,9 @@ service_DATA = $(service_in_files:.service.in=.service)
$(service_DATA): $(service_in_files) Makefile
@sed -e "s|\@servicedir\@|$(bindir)|" $< > $@
+@GSETTINGS_RULES@
+gsettings_SCHEMAS = org.mate.power-manager.gschema.xml
+
pkgdata_DATA = \
gpm-statistics.ui \
gpm-statistics-deprecated.ui \
@@ -32,25 +31,12 @@ pkgdata_DATA = \
acme.ui
EXTRA_DIST = \
- mate-power-manager.schemas.in \
- $(schema_in_files) \
- $(desktop_in_files) \
- $(autostart_in_files) \
+ $(gsettings_SCHEMAS) \
$(service_in_files) \
+ $(autostart_in_files) \
+ $(desktop_in_files) \
$(pkgdata_DATA)
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- -MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) \
- $(MATECONFTOOL) --makefile-install-rule $(schema_DATA)
-endif
-
-if MATECONF_SCHEMAS_INSTALL
-uninstall-local:
- -MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) \
- $(MATECONFTOOL) --makefile-uninstall-rule $(schema_DATA)
-endif
-
clean-local :
rm -f *~
@@ -58,5 +44,4 @@ DISTCLEANFILES = \
mate-power-manager.desktop \
mate-power-preferences.desktop \
mate-power-statistics.desktop \
- mate-power-manager.schemas \
mate-power-manager.service