summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-11 12:55:19 +0100
committerStefano Karapetsas <[email protected]>2011-12-11 12:55:19 +0100
commit51175189c6d7313a3b84019e39496f957c4e6164 (patch)
treee4c2c130fa3140bca28685ef900f04a012e53dcd /man/Makefile.am
downloadmate-power-manager-51175189c6d7313a3b84019e39496f957c4e6164.tar.bz2
mate-power-manager-51175189c6d7313a3b84019e39496f957c4e6164.tar.xz
moved from Mate-Extra
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..aa1f8ec
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,27 @@
+EXTRA_DIST = \
+ mate-power-manager.sgml \
+ mate-power-statistics.sgml \
+ mate-power-preferences.sgml
+
+if HAVE_DOCBOOK2MAN
+man_MANS = \
+ mate-power-manager.1 \
+ mate-power-statistics.1 \
+ mate-power-preferences.1
+endif
+
+if HAVE_DOCBOOK2MAN
+mate-power-manager.1: mate-power-manager.sgml
+ docbook2man $? &> /dev/null
+
+mate-power-preferences.1: mate-power-preferences.sgml
+ docbook2man $? &> /dev/null
+
+mate-power-statistics.1: mate-power-statistics.sgml
+ docbook2man $? &> /dev/null
+endif
+
+clean-local :
+ rm -f *~
+ rm -f *.1
+ rm -f manpage.*