summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-10-25 14:33:23 +0300
committermonsta <[email protected]>2016-10-25 15:11:30 +0300
commited81e790565663f1ddbdf0777efbd01b8b0e00ad (patch)
tree7fd19e6c621ca1b7909a760eff5074f6230cab5a /Makefile.am
parent257ffb3cc4b1eab35630a9e53b6c29dda0b899da (diff)
downloadmate-system-monitor-ed81e790565663f1ddbdf0777efbd01b8b0e00ad.tar.bz2
mate-system-monitor-ed81e790565663f1ddbdf0777efbd01b8b0e00ad.tar.xz
add pkexec support
closes https://github.com/mate-desktop/mate-system-monitor/issues/85 try pkexec before trying gksu for killing other users' processes or renicing a process. actual kill and renice commands are launched via helper tool (see discussion at https://bugzilla.gnome.org/491462). code is ported from gnome-system-monitor with some changes (e.g. helper tool code is in tools/ dir instead of scripts/ - it's not a script). for reference - relevant upstream commits: https://git.gnome.org/browse/gnome-system-monitor/commit/?id=ccbff2a4293e43d6ea24fbf13477b10f58cd5212 https://git.gnome.org/browse/gnome-system-monitor/commit/?id=2b4308d9fc2b2e367030629e79b531c4f9ae3d0a https://git.gnome.org/browse/gnome-system-monitor/commit/?id=971b3c704dea49b22c1038f200933c5b3b35ece1 https://git.gnome.org/browse/gnome-system-monitor/commit/?id=c234b2a75dac454b818f1f40d302cf12f1a33aa2 https://git.gnome.org/browse/gnome-system-monitor/commit/?id=4cda3529e418098b35f7444d79ba421eb5403afc https://git.gnome.org/browse/gnome-system-monitor/commit/?id=ab7bd8aef7300eeb3835fdef9a2a1eefe7281631 https://git.gnome.org/browse/gnome-system-monitor/commit/?id=79eccf0cecbca237f4f911681438c33932da63e2 https://git.gnome.org/browse/gnome-system-monitor/commit/?id=a3bf3a7f56cf02c6a127aa168c570230e9fad356
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 38912bf..9cced9e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = pixmaps po src help
+SUBDIRS = pixmaps po src tools help
man_MANS = mate-system-monitor.1
@@ -11,10 +11,14 @@ appdatadir = $(datadir)/appdata
appdata_in_files = mate-system-monitor.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+org.mate.mate-system-monitor.policy.in: org.mate.mate-system-monitor.policy.in.in Makefile
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
EXTRA_DIST = \
autogen.sh \
$(man_MANS) \
$(appdata_in_files) \
+ org.mate.mate-system-monitor.policy.in.in \
mate-system-monitor.desktop.in \
intltool-extract.in \
intltool-merge.in \
@@ -22,6 +26,11 @@ EXTRA_DIST = \
omf.make \
xmldocs.make
+@INTLTOOL_POLICY_RULE@
+polkit_policydir = $(datadir)/polkit-1/actions
+polkit_policy_in_files = org.mate.mate-system-monitor.policy.in
+polkit_policy_DATA = $(polkit_policy_in_files:.policy.in=.policy)
+
Applicationsdir = $(datadir)/applications
Applications_in_files = mate-system-monitor.desktop.in
Applications_DATA = $(Applications_in_files:.desktop.in=.desktop)
@@ -35,7 +44,9 @@ DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update \
- mate-system-monitor.desktop
+ mate-system-monitor.desktop \
+ org.mate.mate-system-monitor.policy \
+ org.mate.mate-system-monitor.policy.in
# Build ChangeLog from GIT history
ChangeLog: