summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac149
1 files changed, 0 insertions, 149 deletions
diff --git a/configure.ac b/configure.ac
index afd7d55c..2f825208 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,61 +89,6 @@ AC_ARG_ENABLE(all-themes,
[enable_all_themes=no])
AM_CONDITIONAL(CORE_THEMES_ONLY, test "$enable_all_themes" = no)
-### Cursor theme to use for large print desktop themes.
-### TODO: Should probably check whether specified/default themes are
-### installed too, and do something appropriate if not.
-AC_ARG_WITH(lp-cursor-theme,
-[AS_HELP_STRING([--with-lp-cursor-theme=THEME],
- [cursor theme for Large Print desktop theme [default=whiteglass]])],
-[LARGEPRINT_CURSOR_THEME="$withval"],
-[LARGEPRINT_CURSOR_THEME="whiteglass"],
-)
-AC_SUBST(LARGEPRINT_CURSOR_THEME)
-
-AC_ARG_WITH(hclp-cursor-theme,
-[AS_HELP_STRING([--with-hclp-cursor-theme=THEME],
- [cursor theme for High Contrast Large Print desktop theme [default=redglass]])],
-[LARGEPRINT_HC_CURSOR_THEME="$withval"],
-[LARGEPRINT_HC_CURSOR_THEME="redglass"],
-)
-AC_SUBST(LARGEPRINT_HC_CURSOR_THEME)
-
-AC_ARG_WITH(hclpi-cursor-theme,
-[AS_HELP_STRING([--with-hclpi-cursor-theme=THEME],
- [cursor theme for High Contrast Large Print Inverse desktop theme [default=whiteglass]])],
-[LARGEPRINT_HCI_CURSOR_THEME="$withval"],
-[LARGEPRINT_HCI_CURSOR_THEME="whiteglass"],
-)
-AC_SUBST(LARGEPRINT_HCI_CURSOR_THEME)
-
-### Icon sizes for all large print themes
-
-LARGEPRINT_DND="48,48"
-LARGEPRINT_MENU="32,32"
-LARGEPRINT_PANEL_MENU="48,48"
-LARGEPRINT_LARGE_TOOLBAR="48,48"
-LARGEPRINT_SMALL_TOOLBAR="32,32"
-LARGEPRINT_BUTTON="32,32"
-LARGEPRINT_DIALOG="64,64"
-LARGEPRINT_MINI_COMMANDER="24,24"
-
-LARGEPRINT_ICON_SIZES="mini-commander-icon=$LARGEPRINT_MINI_COMMANDER:print-manager=$LARGEPRINT_DIALOG:panel-button=$LARGEPRINT_BUTTON:gtk-dnd=$LARGEPRINT_DND:gtk-menu=$LARGEPRINT_MENU:panel-menu=$LARGEPRINT_PANEL_MENU:gtk-large-toolbar=$LARGEPRINT_LARGE_TOOLBAR:gtk-small-toolbar=$LARGEPRINT_SMALL_TOOLBAR:gtk-button=$LARGEPRINT_BUTTON:gtk-dialog=$LARGEPRINT_DIALOG"
-
-LARGEPRINT_FONT="sans 18"
-LARGEPRINT_DOCUMENTS_FONT="sans 18"
-LARGEPRINT_DESKTOP_FONT="sans 18"
-LARGEPRINT_WINDOW_FONT="sans 18"
-LARGEPRINT_MONOSPACE_FONT="monospace 18"
-LARGEPRINT_CURSOR_SIZE="48"
-
-AC_SUBST(LARGEPRINT_ICON_SIZES)
-AC_SUBST(LARGEPRINT_FONT)
-AC_SUBST(LARGEPRINT_DOCUMENTS_FONT)
-AC_SUBST(LARGEPRINT_DESKTOP_FONT)
-AC_SUBST(LARGEPRINT_WINDOW_FONT)
-AC_SUBST(LARGEPRINT_MONOSPACE_FONT)
-AC_SUBST(LARGEPRINT_CURSOR_SIZE)
-
dnl used to substitute in common sections of theme gtkrc files
gtk_stock_icons_rc=${srcdir}/common/gtk-stock-icons.rc
panel_stock_icons_rc=${srcdir}/common/panel-stock-icons.rc
@@ -161,7 +106,6 @@ Makefile
common/Makefile
cursor-themes/Makefile
desktop-themes/Makefile
-desktop-themes/AlaDelta/Makefile
desktop-themes/BlackMATE/Makefile
desktop-themes/BlackMATE/gtk-2.0/Makefile
desktop-themes/BlackMATE/gtk-2.0/assets/Makefile
@@ -183,11 +127,6 @@ desktop-themes/ContrastHighInverse/gtk-2.0/gtkrc
desktop-themes/ContrastHighInverse/gtk-3.0/Makefile
desktop-themes/ContrastHighInverse/metacity-1/Makefile
desktop-themes/ContrastHighInverse/pixmaps/Makefile
-desktop-themes/ContrastHighLargePrint/Makefile
-desktop-themes/ContrastHighLargePrint/index.theme.in
-desktop-themes/ContrastHighLargePrintInverse/Makefile
-desktop-themes/ContrastHighLargePrintInverse/index.theme.in
-desktop-themes/Fog/Makefile
desktop-themes/GreenLaguna/Makefile
desktop-themes/GreenLaguna/gtk-2.0/Makefile
desktop-themes/GreenLaguna/gtk-2.0/Styles/Makefile
@@ -195,8 +134,6 @@ desktop-themes/GreenLaguna/gtk-3.0/Makefile
desktop-themes/GreenLaguna/gtk-3.0/assets/Makefile
desktop-themes/GreenLaguna/metacity-1/Makefile
desktop-themes/GreenLaguna/unity/Makefile
-desktop-themes/LargePrint/Makefile
-desktop-themes/LargePrint/index.theme.in
desktop-themes/Menta/Makefile
desktop-themes/Menta/cinnamon/Makefile
desktop-themes/Menta/gtk-2.0/Makefile
@@ -235,7 +172,6 @@ desktop-themes/BlueMenta/gtk-3.0/borders/Makefile
desktop-themes/BlueMenta/metacity-1/Makefile
desktop-themes/BlueMenta/unity/Makefile
desktop-themes/BlueMenta/xfwm4/Makefile
-desktop-themes/Quid/Makefile
desktop-themes/TraditionalGreen/Makefile
desktop-themes/TraditionalGreen/gtk-2.0/Makefile
desktop-themes/TraditionalGreen/gtk-3.0/Makefile
@@ -257,16 +193,6 @@ desktop-themes/TraditionalOkTest/gtk-3.0/Makefile
desktop-themes/TraditionalOkTest/gtk-3.0/img/Makefile
desktop-themes/TraditionalOkTest/metacity-1/Makefile
marco-themes/Makefile
-gtk-themes/Makefile
-gtk-themes/AlaDelta/Makefile
-gtk-themes/ContrastHighLargePrint/Makefile
-gtk-themes/ContrastHighLargePrint/gtkrc
-gtk-themes/ContrastHighLargePrintInverse/Makefile
-gtk-themes/ContrastHighLargePrintInverse/gtkrc
-gtk-themes/LargePrint/Makefile
-gtk-themes/LargePrint/gtkrc
-gtk-themes/Reverse/Makefile
-gtk-themes/Simply/Makefile
icon-themes/Makefile
icon-themes/ContrastHigh/Makefile
icon-themes/ContrastHigh/16x16/Makefile
@@ -349,78 +275,6 @@ icon-themes/ContrastHigh/scalable/places/Makefile
icon-themes/ContrastHigh/scalable/places-extra/Makefile
icon-themes/ContrastHigh/scalable/status/Makefile
icon-themes/ContrastHigh/scalable/status-extra/Makefile
-icon-themes/ContrastHighLargePrint/Makefile
-icon-themes/ContrastHighLargePrintInverse/Makefile
-icon-themes/ContrastHighLargePrintInverse/36x36/Makefile
-icon-themes/ContrastHighLargePrintInverse/36x36/animations/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/actions/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/apps/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/categories/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/devices/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/emblems/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/mimetypes/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/places/Makefile
-icon-themes/ContrastHighLargePrintInverse/48x48/status/Makefile
-icon-themes/Fog/22x22/status/Makefile
-icon-themes/Fog/22x22/devices/Makefile
-icon-themes/Fog/22x22/actions/Makefile
-icon-themes/Fog/22x22/places/Makefile
-icon-themes/Fog/22x22/apps/Makefile
-icon-themes/Fog/22x22/Makefile
-icon-themes/Fog/16x16/status/Makefile
-icon-themes/Fog/16x16/devices/Makefile
-icon-themes/Fog/16x16/actions/Makefile
-icon-themes/Fog/16x16/places/Makefile
-icon-themes/Fog/16x16/apps/Makefile
-icon-themes/Fog/16x16/Makefile
-icon-themes/Fog/32x32/status/Makefile
-icon-themes/Fog/32x32/devices/Makefile
-icon-themes/Fog/32x32/actions/Makefile
-icon-themes/Fog/32x32/places/Makefile
-icon-themes/Fog/32x32/apps/Makefile
-icon-themes/Fog/32x32/Makefile
-icon-themes/Fog/Makefile
-icon-themes/Fog/48x48/status/Makefile
-icon-themes/Fog/48x48/devices/Makefile
-icon-themes/Fog/48x48/actions/Makefile
-icon-themes/Fog/48x48/places/Makefile
-icon-themes/Fog/48x48/apps/Makefile
-icon-themes/Fog/48x48/Makefile
-icon-themes/Fog/24x24/status/Makefile
-icon-themes/Fog/24x24/devices/Makefile
-icon-themes/Fog/24x24/actions/Makefile
-icon-themes/Fog/24x24/places/Makefile
-icon-themes/Fog/24x24/apps/Makefile
-icon-themes/Fog/24x24/Makefile
-icon-themes/Fog/256x256/status/Makefile
-icon-themes/Fog/256x256/devices/Makefile
-icon-themes/Fog/256x256/actions/Makefile
-icon-themes/Fog/256x256/places/Makefile
-icon-themes/Fog/256x256/apps/Makefile
-icon-themes/Fog/256x256/Makefile
-icon-themes/LargePrint/Makefile
-icon-themes/Quid/Makefile
-icon-themes/Quid/16x16/Makefile
-icon-themes/Quid/16x16/actions/Makefile
-icon-themes/Quid/16x16/status/Makefile
-icon-themes/Quid/16x16/places/Makefile
-icon-themes/Quid/22x22/Makefile
-icon-themes/Quid/22x22/actions/Makefile
-icon-themes/Quid/22x22/status/Makefile
-icon-themes/Quid/22x22/places/Makefile
-icon-themes/Quid/24x24/Makefile
-icon-themes/Quid/24x24/actions/Makefile
-icon-themes/Quid/24x24/status/Makefile
-icon-themes/Quid/24x24/places/Makefile
-icon-themes/Quid/32x32/Makefile
-icon-themes/Quid/32x32/actions/Makefile
-icon-themes/Quid/32x32/status/Makefile
-icon-themes/Quid/32x32/places/Makefile
-icon-themes/Quid/scalable/Makefile
-icon-themes/Quid/scalable/actions/Makefile
-icon-themes/Quid/scalable/status/Makefile
-icon-themes/Quid/scalable/places/Makefile
po/Makefile.in
])
@@ -435,8 +289,5 @@ mate-themes-$VERSION:
Enable placeholders: ${enable_placeholders}
Enable legacy icons: ${enable_mapping}
Enable all themes: ${enable_all_themes}
- LargePrint cursor theme: ${LARGEPRINT_CURSOR_THEME}
- HC LargePrint cursor theme: ${LARGEPRINT_HC_CURSOR_THEME}
- HCI LargePrint cursor theme: ${LARGEPRINT_HCI_CURSOR_THEME}
"