summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-01-12 18:28:35 +0100
committerStefano Karapetsas <[email protected]>2012-01-12 18:28:35 +0100
commite87fbefcec0c44579495b1bcb22ac59814029566 (patch)
treee6f14613713d8e431dc26868e50e1d12900beb8a /Makefile.am
downloadmozo-e87fbefcec0c44579495b1bcb22ac59814029566.tar.bz2
mozo-e87fbefcec0c44579495b1bcb22ac59814029566.tar.xz
import from Mate-Extra
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9611bc7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = data po Alacarte
+
+CLEANFILES=
+
+bin_SCRIPTS = alacarte
+CLEANFILES += alacarte
+
+DISTCLEANFILES = ChangeLog
+
+alacarte: alacarte.in
+ sed -e s!\@PYTHON\@!@PYTHON@! \
+ -e s!\@PYOPTIONS\@!-OOt! \
+ < $< > $@
+alacarte: Makefile
+
+EXTRA_DIST = \
+ alacarte.in \
+ MAINTAINERS \
+ ChangeLog.pre-git
+
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log git-migration.. --stat -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
+ && mv -f [email protected] $@ \
+ || ($(RM) [email protected]; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog
+