summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2015-09-29 13:38:04 +0300
committermonsta <[email protected]>2015-09-29 13:38:04 +0300
commite39f5b99d14fcddbd295e2d792980a11b379b1f7 (patch)
tree476eef204936c6a84e50d2894d8dccd8bc6dcbd8 /Makefile.am
parentab4da31e0815c8c7931c7075d7b7c54c6666106e (diff)
downloadpluma-e39f5b99d14fcddbd295e2d792980a11b379b1f7.tar.bz2
pluma-e39f5b99d14fcddbd295e2d792980a11b379b1f7.tar.xz
added --enable-tests option which will be off during distcheck
as we have document-saver test failing always
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1de33aa5..acb0ea0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,11 @@
## Process this file with automake to produce Makefile.in
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = pluma pixmaps po data plugin-loaders plugins docs tests help
+SUBDIRS = pluma pixmaps po data plugin-loaders plugins docs help
+
+if ENABLE_TESTS
+ SUBDIRS += tests
+endif
distuninstallcheck_listfiles = find . -type f -print
@@ -51,7 +55,7 @@ MAINTAINERCLEANFILES = \
m4/lt~obsolete.m4 \
`find "$(srcdir)" -type f -name Makefile.in -print`
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --disable-tests
dist-hook:
@if test -d "$(srcdir)/.git"; \