summaryrefslogtreecommitdiff
path: root/plugins/checkupdate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/checkupdate/Makefile.am')
-rw-r--r--plugins/checkupdate/Makefile.am40
1 files changed, 0 insertions, 40 deletions
diff --git a/plugins/checkupdate/Makefile.am b/plugins/checkupdate/Makefile.am
deleted file mode 100644
index 38fd5bbc..00000000
--- a/plugins/checkupdate/Makefile.am
+++ /dev/null
@@ -1,40 +0,0 @@
-# pluma win32 updater
-
-plugindir = $(PLUMA_PLUGINS_LIBS_DIR)
-
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- $(PLUMA_CFLAGS) \
- $(LIBSOUP_CFLAGS) \
- $(WARN_CFLAGS) \
- $(DISABLE_DEPRECATED_CFLAGS)
-
-plugin_LTLIBRARIES = libcheckupdate.la
-
-libcheckupdate_la_SOURCES = \
- pluma-check-update-plugin.h \
- pluma-check-update-plugin.c
-
-libcheckupdate_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
-libcheckupdate_la_LIBADD = $(PLUMA_LIBS) $(LIBSOUP_LIBS)
-
-plugin_in_files = checkupdate.pluma-plugin.desktop.in
-
-%.pluma-plugin: %.pluma-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-
-plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
-
-@INTLTOOL_XML_NOMERGE_RULE@
-gsettings_SCHEMAS = org.mate.pluma.plugins.checkupdate.gschema.xml
-@GSETTINGS_RULES@
-
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
-EXTRA_DIST = $(plugin_in_files) $(gsettings_SCHEMAS).in.in
-
-CLEANFILES = $(plugin_DATA) $(gsettings_SCHEMAS).in $(gsettings_SCHEMAS)
-
-DISTCLEANFILES = $(plugin_DATA) $(gsettings_SCHEMAS).in $(gsettings_SCHEMAS)
-
--include $(top_srcdir)/git.mk