summaryrefslogtreecommitdiff
path: root/pluma/osx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pluma/osx/Makefile.am')
-rwxr-xr-xpluma/osx/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/pluma/osx/Makefile.am b/pluma/osx/Makefile.am
new file mode 100755
index 00000000..994b9ff7
--- /dev/null
+++ b/pluma/osx/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/pluma \
+ -I$(top_builddir)/pluma \
+ $(PLUMA_CFLAGS) \
+ $(IGE_MAC_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+noinst_LTLIBRARIES = libosx.la
+
+libosx_la_LDFLAGS = -framework Carbon -framework ApplicationServices -framework Cocoa
+libosx_la_LIBADD = -lobjc
+libosx_la_CFLAGS = -xobjective-c
+
+libosx_la_SOURCES = \
+ pluma-osx.c \
+ pluma-osx.h \
+ pluma-osx-delegate.m \
+ pluma-osx-delegate.h
+
+-include $(top_srcdir)/git.mk