summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-09 18:17:43 -0300
committerPerberos <[email protected]>2011-11-09 18:17:43 -0300
commitf6ce926719943751cf65cacde7fae050593eb2d6 (patch)
tree9224d1751678cf2d1fbd0431f128b711311c0287 /Makefile.am
downloadatril-f6ce926719943751cf65cacde7fae050593eb2d6.tar.bz2
atril-f6ce926719943751cf65cacde7fae050593eb2d6.tar.xz
inicial
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am116
1 files changed, 116 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..2468dae4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,116 @@
+ACLOCAL_AMFLAGS = -I m4
+
+# Set the minimum required Windows version to Windows 2000 (0x0500).
+if PLATFORM_WIN32
+AM_CPPFLAGS = -D_WIN32_WINNT=0x0500
+endif
+
+SUBDIRS = \
+ cut-n-paste \
+ data \
+ libdocument \
+ backend \
+ libview \
+ libmisc \
+ properties \
+ shell \
+ po \
+ help
+
+if ENABLE_TESTS
+SUBDIRS += test
+endif
+
+if ENABLE_THUMBNAILER
+SUBDIRS += thumbnailer
+endif
+
+if ENABLE_PREVIEWER
+SUBDIRS += previewer
+endif
+
+NULL =
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = \
+ evince-document-$(EV_API_VERSION).pc \
+ evince-view-$(EV_API_VERSION).pc \
+ $(NULL)
+
+headerdir = $(includedir)/evince/$(EV_API_VERSION)
+header_DATA = \
+ evince-document.h \
+ evince-view.h \
+ $(NULL)
+
+# Applications
+
+intltool_extra = intltool-extract.in intltool-merge.in intltool-update.in
+
+EXTRA_DIST = \
+ $(intltool_extra) \
+ $(header_DATA) \
+ autogen.sh \
+ mate-doc-utils.make \
+ MAINTAINERS
+
+DISTCLEANFILES = \
+ mate-doc-utils.make \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
+
+MAINTAINERCLEANFILES = \
+ ChangeLog \
+ $(srcdir)/INSTALL \
+ $(srcdir)/aclocal.m4 \
+ $(srcdir)/autoscan.log \
+ $(srcdir)/compile \
+ $(srcdir)/config.guess \
+ $(srcdir)/config.h.in \
+ $(srcdir)/config.sub \
+ $(srcdir)/configure \
+ $(srcdir)/configure.scan \
+ $(srcdir)/depcomp \
+ $(srcdir)/install-sh \
+ $(srcdir)/ltmain.sh \
+ $(srcdir)/missing \
+ $(srcdir)/mkinstalldirs \
+ $(srcdir)/omf.make \
+ $(srcdir)/xmldocs.make \
+ $(srcdir)/gtk-doc.make \
+ $(srcdir)/po/Makefile.in.in \
+ `find "$(srcdir)" -type f -name Makefile.in -print`
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-schemas-install \
+ --disable-scrollkeeper \
+ --enable-gtk-doc \
+ --disable-caja \
+ --disable-tests \
+ --disable-silent-rules
+
+# Ignore scrollkeeper issues for now. @#*$& scrollkeeper
+distuninstallcheck_listfiles = find . -type f -print | grep -v scrollkeeper | grep -v /share/mate/help/ | grep -v \.omf
+
+distclean-local:
+ if test "$(srcdir)" = "."; then :; else \
+ rm -f ChangeLog; \
+ fi
+
+ChangeLog:
+ $(AM_V_GEN) if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
+ && mv -f [email protected] $@ \
+ || ($(RM) [email protected]; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog
+
+-include $(top_srcdir)/git.mk