summaryrefslogtreecommitdiff
path: root/backend/Makefile.am
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-06-19 14:19:48 +0530
committerrootavish <[email protected]>2014-06-19 14:19:48 +0530
commitd57fa16e9e8c9091ebf826af94a0c3ad1a593596 (patch)
tree3969514d475a92c977fa15ee7e19ac37d5fe3575 /backend/Makefile.am
parent3fd3e5708b0566b1392fa5e7f37a18de137a43e0 (diff)
downloadatril-d57fa16e9e8c9091ebf826af94a0c3ad1a593596.tar.bz2
atril-d57fa16e9e8c9091ebf826af94a0c3ad1a593596.tar.xz
Epub backend builds as a part of Atril compilation
Fixed a tabbing error in backend/Makefile.am due to which the epub backend was not a target when building recursilvely, i am not commiting the changes to epub-document.c as currently it will break the build, hope to fix it and get webkit and mathjax done by the weekend. Also fixed an error in configure.ac wherin the appearance of AM_LIBTOOL_PROG before AC_CXX_PROG caused a "link:unsupported hardcode properties error" on Linux Mint.
Diffstat (limited to 'backend/Makefile.am')
-rw-r--r--backend/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/backend/Makefile.am b/backend/Makefile.am
index 1c042067..49bfdf6a 100644
--- a/backend/Makefile.am
+++ b/backend/Makefile.am
@@ -6,6 +6,10 @@ if ENABLE_PDF
SUBDIRS += pdf
endif
+if ENABLE_EPUB
+SUBDIRS += epub
+endif
+
if ENABLE_PS
SUBDIRS += ps
endif
@@ -34,10 +38,6 @@ if ENABLE_XPS
SUBDIRS += xps
endif
-if ENABLE_EPUB
- SUBDIRS += epub
-endif
-
EXTRA_DIST = \
backend.symbols