summaryrefslogtreecommitdiff
path: root/backend/epub/Makefile.am
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-05-30 00:11:14 +0530
committerrootavish <[email protected]>2014-05-30 00:11:14 +0530
commit070a26ed403e9a0c330ee7901c5b85394317ef77 (patch)
tree89e5d8ac085a519672b673d276dbc1837d3e96f0 /backend/epub/Makefile.am
parent0a4d3f34a8aee74019759ace24f84672a98122b4 (diff)
downloadatril-070a26ed403e9a0c330ee7901c5b85394317ef77.tar.bz2
atril-070a26ed403e9a0c330ee7901c5b85394317ef77.tar.xz
Added functions to extract epub archive,fixed header
In this commit i added functionality to extract an epub archive to a temporary location.Again i tried to keep the design modular. This will be changed as changes come along. I also fixed the header to the standard atril backend header. Performed some code cleaning, naming functions as in the atril style of coding.
Diffstat (limited to 'backend/epub/Makefile.am')
-rw-r--r--backend/epub/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/backend/epub/Makefile.am b/backend/epub/Makefile.am
index 4371cde8..252fea2a 100644
--- a/backend/epub/Makefile.am
+++ b/backend/epub/Makefile.am
@@ -10,8 +10,12 @@ AM_CPPFLAGS = \
backend_LTLIBRARIES = libepubdocument.la
libepubdocument_la_SOURCES = \
- epub-document.c \
- epub-document.h
+ epub-document.c \
+ epub-document.h \
+ ioapi.c \
+ ioapi.h \
+ unzip.c \
+ unzip.h
libepubdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libepubdocument_la_LIBADD = \