summaryrefslogtreecommitdiff
path: root/backend/epub/Makefile.am
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-05-24 05:38:31 +0530
committerrootavish <[email protected]>2014-05-24 05:38:31 +0530
commit0a4d3f34a8aee74019759ace24f84672a98122b4 (patch)
treefc5b775f1656f242e38f23bbf93d86cbcf22d307 /backend/epub/Makefile.am
parent28b2c08f60f54a78596746e204f4d0092587a09a (diff)
downloadatril-0a4d3f34a8aee74019759ace24f84672a98122b4.tar.bz2
atril-0a4d3f34a8aee74019759ace24f84672a98122b4.tar.xz
XML parsing for ePub
using libxml some functions were written which will be used to get keywords,attributes from files such as the ePub container.tried to keep the code generalised so as to facilitate reusability of code.
Diffstat (limited to 'backend/epub/Makefile.am')
-rw-r--r--backend/epub/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/backend/epub/Makefile.am b/backend/epub/Makefile.am
index 6ecbdb2a..4371cde8 100644
--- a/backend/epub/Makefile.am
+++ b/backend/epub/Makefile.am
@@ -1,4 +1,4 @@
-AM_CPPFLAGS = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_srcdir)/libdocument \
-DMATELOCALEDIR=\"$(datadir)/locale\" \
@@ -9,8 +9,9 @@ AM_CPPFLAGS = \
backend_LTLIBRARIES = libepubdocument.la
-libepubdocument_la_SOURCES =
-
+libepubdocument_la_SOURCES = \
+ epub-document.c \
+ epub-document.h
libepubdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libepubdocument_la_LIBADD = \