summaryrefslogtreecommitdiff
path: root/backend/epub/Makefile.am
diff options
context:
space:
mode:
authorrootavish <[email protected]>2014-05-30 21:57:13 +0530
committerrootavish <[email protected]>2014-05-30 22:23:05 +0530
commit415b008bff9de46176ed39daa2ffece45cdd2506 (patch)
tree53d6b70cd67eda8cf79b84809db90fef5ddc80aa /backend/epub/Makefile.am
parent7f33c3425aae32d1dd5d2d7b912f8d4eac1cf85d (diff)
downloadatril-415b008bff9de46176ed39daa2ffece45cdd2506.tar.bz2
atril-415b008bff9de46176ed39daa2ffece45cdd2506.tar.xz
Created a Makefile for minizip, modified epub Makefile
I created a Makefile for the minizip backend, since i am only using part of that library and modified the epub backend to work with the library. Also modified the configure script to suit our purpose. The epub backend can now be compiled using the make command in the epub directory, although it cannot still be compiled as a part of atril.
Diffstat (limited to 'backend/epub/Makefile.am')
-rw-r--r--backend/epub/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/backend/epub/Makefile.am b/backend/epub/Makefile.am
index 252fea2a..a40f5ff1 100644
--- a/backend/epub/Makefile.am
+++ b/backend/epub/Makefile.am
@@ -1,25 +1,25 @@
AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_srcdir)/libdocument \
+ -I$(srcdir)/minizip \
-DMATELOCALEDIR=\"$(datadir)/locale\" \
-DATRIL_COMPILATION \
$(BACKEND_CFLAGS) \
$(WARN_CXXFLAGS) \
+ $(WEBKIT_CFLAGS) \
$(DISABLE_DEPRECATED)
backend_LTLIBRARIES = libepubdocument.la
libepubdocument_la_SOURCES = \
epub-document.c \
- epub-document.h \
- ioapi.c \
- ioapi.h \
- unzip.c \
- unzip.h
+ epub-document.h
libepubdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
libepubdocument_la_LIBADD = \
$(top_builddir)/libdocument/libatrildocument.la \
+ minizip/libminizip.la \
+ $(WEBKIT_LIBS) \
$(BACKEND_LIBS)