summaryrefslogtreecommitdiff
path: root/backend/epub/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-09-21 17:11:13 +0200
committerStefano Karapetsas <[email protected]>2014-09-21 17:11:13 +0200
commit5ac452a8a78841bf88dee6e7b0a9ea421299f669 (patch)
tree9989800bd8b0496fce4687673f8410b63b02a69f /backend/epub/Makefile.am
parent1bdae54253b68f2042f1d7f43ac0f36654c9b432 (diff)
parent67bb00b6c5105dc840b968db513a1e26bac7b2e0 (diff)
downloadatril-5ac452a8a78841bf88dee6e7b0a9ea421299f669.tar.bz2
atril-5ac452a8a78841bf88dee6e7b0a9ea421299f669.tar.xz
Merge pull request #84 from rootAvish/epub
Epub support in Atril
Diffstat (limited to 'backend/epub/Makefile.am')
-rw-r--r--backend/epub/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/backend/epub/Makefile.am b/backend/epub/Makefile.am
new file mode 100644
index 00000000..169f16c7
--- /dev/null
+++ b/backend/epub/Makefile.am
@@ -0,0 +1,37 @@
+SUBDIRS = minizip MathJax
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libdocument \
+ -I$(srcdir)/minizip \
+ -DMATELOCALEDIR=\"$(datadir)/locale\" \
+ -DATRIL_COMPILATION \
+ $(BACKEND_CFLAGS) \
+ $(WARN_CXXFLAGS) \
+ $(EPUB_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+backend_LTLIBRARIES = libepubdocument.la
+
+libepubdocument_la_SOURCES = \
+ epub-document.c \
+ epub-document.h
+
+libepubdocument_la_LDFLAGS = $(BACKEND_LIBTOOL_FLAGS)
+libepubdocument_la_LIBADD = \
+ $(top_builddir)/libdocument/libatrildocument.la \
+ minizip/libminizip.la \
+ $(EPUB_LIBS) \
+ $(BACKEND_LIBS)
+
+
+backend_in_files = epubdocument.atril-backend.in
+backend_DATA = $(backend_in_files:.atril-backend.in=.atril-backend)
+
+EXTRA_DIST = $(backend_in_files)
+
+CLEANFILES = $(backend_DATA)
+
+@EV_INTLTOOL_ATRIL_BACKEND_RULE@
+
+-include $(top_srcdir)/git.mk