summaryrefslogtreecommitdiff
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
authorMonsta <[email protected]>2015-08-24 22:25:31 +0300
committerinfirit <[email protected]>2015-08-31 14:51:17 +0200
commite5e2b894e070fd0509c0016e7285d78c6ff543c3 (patch)
tree6b52f77438b32132f46da5521b3ccc693ba10123 /cut-n-paste/smclient/Makefile.am
parent0f060b5170016a28cf742edbc623dea906fa7f15 (diff)
downloadatril-e5e2b894e070fd0509c0016e7285d78c6ff543c3.tar.bz2
atril-e5e2b894e070fd0509c0016e7285d78c6ff543c3.tar.xz
drop support for win32/osx/hildon, make smclient mandatory
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am24
1 files changed, 4 insertions, 20 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
index f99d40b1..6affe94d 100644
--- a/cut-n-paste/smclient/Makefile.am
+++ b/cut-n-paste/smclient/Makefile.am
@@ -1,16 +1,17 @@
noinst_LTLIBRARIES = libsmclient.la
-NULL =
-
-if WITH_SMCLIENT
libsmclient_la_SOURCES = \
eggsmclient.c \
eggsmclient.h \
eggsmclient-private.h \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient-xsmp.c \
$(NULL)
libsmclient_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\""EggSMClient"\" \
+ -DEGG_SM_CLIENT_BACKEND_XSMP \
$(DISABLE_DEPRECATED) \
$(AM_CPPFLAGS)
@@ -23,21 +24,4 @@ libsmclient_la_LIBADD = \
$(SMCLIENT_LIBS) \
-lICE
-if WITH_SMCLIENT_XSMP
-libsmclient_la_SOURCES += \
- eggdesktopfile.c \
- eggdesktopfile.h \
- eggsmclient-xsmp.c \
- $(NULL)
-libsmclient_la_CPPFLAGS += -DEGG_SM_CLIENT_BACKEND_XSMP
-endif
-if WITH_SMCLIENT_WIN32
-libsmclient_la_SOURCES += eggsmclient-win32.c
-endif
-if WITH_SMCLIENT_QUARTZ
-libsmclient_la_SOURCES += eggsmclient-osx.c
-endif
-
-endif # WITH_SMCLIENT
-
-include $(top_srcdir)/git.mk