summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-11-04 17:37:08 +0800
committerZenWalker <[email protected]>2019-11-11 01:18:10 +0100
commitd19b62785293db5999bb14b6ebb611aa76a7253a (patch)
tree07995725258e0f67bd91c0692110e335bbd6c82f /data/Makefile.am
parent73c0bb35bfc355eaa2842652f6a85a58592fb1c2 (diff)
downloadatril-d19b62785293db5999bb14b6ebb611aa76a7253a.tar.bz2
atril-d19b62785293db5999bb14b6ebb611aa76a7253a.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index c6606d01..de20e8cc 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -21,13 +21,13 @@ ui_DATA = \
# Desktop file
#
-@INTLTOOL_DESKTOP_RULE@
-
DESKTOP_IN_FILES= atril.desktop.in.in
DESKTOP_FILES= $(DESKTOP_IN_FILES:.desktop.in.in=.desktop)
desktopdir = $(datadir)/applications
desktop_DATA = $(DESKTOP_FILES)
+$(desktop_DATA): $(DESKTOP_IN_FILES)
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
#
# DBus servide file
@@ -44,10 +44,11 @@ endif
#
# App data file
#
-@INTLTOOL_XML_NOMERGE_RULE@
appdatadir = $(datadir)/metainfo
appdata_in_files = atril.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+$(appdata_DATA): $(appdata_in_files)
+ $(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
#
# GSettings schema