summaryrefslogtreecommitdiff
path: root/properties/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-11-09 18:17:43 -0300
committerPerberos <[email protected]>2011-11-09 18:17:43 -0300
commitf6ce926719943751cf65cacde7fae050593eb2d6 (patch)
tree9224d1751678cf2d1fbd0431f128b711311c0287 /properties/Makefile.am
downloadatril-f6ce926719943751cf65cacde7fae050593eb2d6.tar.bz2
atril-f6ce926719943751cf65cacde7fae050593eb2d6.tar.xz
inicial
Diffstat (limited to 'properties/Makefile.am')
-rw-r--r--properties/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/properties/Makefile.am b/properties/Makefile.am
new file mode 100644
index 00000000..3ef1b82c
--- /dev/null
+++ b/properties/Makefile.am
@@ -0,0 +1,35 @@
+INCLUDES= \
+ -DEVINCEDATADIR=\"$(pkgdatadir)\" \
+ -DMATELOCALEDIR=\"$(datadir)/locale\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(FRONTEND_CFLAGS) \
+ $(CAJA_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS)
+
+noinst_LTLIBRARIES = libevproperties.la
+
+libevproperties_la_SOURCES= \
+ ev-properties-view.c \
+ ev-properties-view.h
+
+if ENABLE_CAJA
+
+cajaextension_LTLIBRARIES = libevince-properties-page.la
+
+libevince_properties_page_la_CFLAGS = -I$(top_srcdir)
+libevince_properties_page_la_SOURCES = \
+ ev-properties-main.c
+
+libevince_properties_page_la_LIBADD = \
+ libevproperties.la \
+ $(top_builddir)/libdocument/libevdocument.la \
+ $(FRONTEND_LIBS) \
+ $(CAJA_LIBS)
+
+libevince_properties_page_la_LDFLAGS = -module -avoid-version -no-undefined
+
+endif # ENABLE_CAJA
+
+-include $(top_srcdir)/git.mk