summaryrefslogtreecommitdiff
path: root/backend/pdf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backend/pdf/Makefile.am')
-rw-r--r--backend/pdf/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/backend/pdf/Makefile.am b/backend/pdf/Makefile.am
index 8634bb63..e51dfdca 100644
--- a/backend/pdf/Makefile.am
+++ b/backend/pdf/Makefile.am
@@ -22,13 +22,14 @@ libpdfdocument_la_LIBADD = \
$(CAIRO_PDF_LIBS) \
$(CAIRO_PS_LIBS)
-backend_in_files = pdfdocument.atril-backend.in
-backend_DATA = $(backend_in_files:.atril-backend.in=.atril-backend)
+backend_in_files = pdfdocument.atril-backend.desktop.in
+backend_DATA = $(backend_in_files:.atril-backend.desktop.in=.atril-backend)
EXTRA_DIST = $(backend_in_files)
CLEANFILES = $(backend_DATA)
-@EV_INTLTOOL_ATRIL_BACKEND_RULE@
+$(backend_DATA): $(backend_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=TypeDescription --template $< -d $(top_srcdir)/po -o $@
-include $(top_srcdir)/git.mk