summaryrefslogtreecommitdiff
path: root/backend/pixbuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backend/pixbuf/Makefile.am')
-rw-r--r--backend/pixbuf/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/backend/pixbuf/Makefile.am b/backend/pixbuf/Makefile.am
index 26b43c51..194c6be5 100644
--- a/backend/pixbuf/Makefile.am
+++ b/backend/pixbuf/Makefile.am
@@ -18,13 +18,13 @@ libpixbufdocument_la_LIBADD = \
$(top_builddir)/libdocument/libatrildocument.la \
$(BACKEND_LIBS)
-backend_in_files = pixbufdocument.atril-backend.in
-backend_DATA = $(backend_in_files:.atril-backend.in=.atril-backend)
+backend_in_files = pixbufdocument.atril-backend.desktop.in
+backend_DATA = $(backend_in_files:.atril-backend.desktop.in=.atril-backend)
+$(backend_DATA): $(backend_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=TypeDescription --template $< -d $(top_srcdir)/po -o $@
EXTRA_DIST = $(backend_in_files)
CLEANFILES = $(backend_DATA)
-@EV_INTLTOOL_ATRIL_BACKEND_RULE@
-
-include $(top_srcdir)/git.mk