summaryrefslogtreecommitdiff
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 0f82bde5..bc29d864 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -19,6 +19,7 @@ AM_CPPFLAGS= \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-DATRIL_COMPILATION \
$(SHELL_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -115,7 +116,8 @@ atril_LDADD= \
$(top_builddir)/libdocument/libatrildocument.la \
$(top_builddir)/libview/libatrilview.la \
$(top_builddir)/libmisc/libevmisc.la \
- $(SHELL_LIBS)
+ $(SHELL_LIBS) \
+ $(MATE_DESKTOP_LIBS)
if PLATFORM_WIN32
atril_LDADD += atril-icon.o