summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-07-17 12:18:35 +0200
committerinfirit <[email protected]>2014-07-17 12:18:35 +0200
commit3bd6fc73c8287c92f5d6a84a1e9e45e906ec36e7 (patch)
treeb41f26a2c5c4e7ad5768e957fb4ce52556e05bbf /Makefile.am
parent68a6fc1faaeb47d82347e3f5390ac4bda2cad561 (diff)
downloadcaja-dropbox-3bd6fc73c8287c92f5d6a84a1e9e45e906ec36e7.tar.bz2
caja-dropbox-3bd6fc73c8287c92f5d6a84a1e9e45e906ec36e7.tar.xz
docgen: Don't use stdin and stdout
The encoding on stdin and stdout are usually ascii and may cause problems with writing unicode to it. Instead of this we open the file directly and avoid dealing with annoying unicode encode/decode errors.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8985128..e420332 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@ caja-dropbox: caja-dropbox.in serializeimages.py
chmod +x caja-dropbox
caja-dropbox.1: caja-dropbox.txt.in caja-dropbox docgen.py
- python docgen.py $(PACKAGE_VERSION) < caja-dropbox.txt.in > caja-dropbox.txt
+ python docgen.py $(PACKAGE_VERSION) caja-dropbox.txt.in caja-dropbox.txt
$(RST2MAN) caja-dropbox.txt > caja-dropbox.1
SUBDIRS = data src