summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXiaotian Wu <[email protected]>2023-10-16 10:42:27 +0800
committerraveit65 <[email protected]>2023-10-24 09:25:00 +0200
commit652e145d2c5e2a9658eed7a665fe5a295503940b (patch)
treee7c0c3e87a4156443cca41716f0a125ab1f4b099 /configure.ac
parentdac72f1d7b4ab1f24bdc64bd2b3f96bd0e30e489 (diff)
downloadcaja-extensions-652e145d2c5e2a9658eed7a665fe5a295503940b.tar.bz2
caja-extensions-652e145d2c5e2a9658eed7a665fe5a295503940b.tar.xz
sendto: require gupnp-1.6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a6c506c..5fedb4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ if test "x$enable_sendto" = "xyes"; then
GTHREAD_REQUIRED=2.6.0
DBUS_REQUIRED=1.0
DBUS_GLIB_REQUIRED=0.60
- GUPNP_REQUIRED=0.13
+ GUPNP_REQUIRED=1.6
PKG_CHECK_MODULES(SENDTO,
glib-2.0 >= $GLIB_REQUIRED
gthread-2.0 >= $GTHREAD_REQUIRED
@@ -214,9 +214,7 @@ if test "x$enable_sendto" = "xyes"; then
fi
;;
upnp)
- PKG_CHECK_MODULES(UPNP, gupnp-1.2 >= $GUPNP_REQUIRED,
- enable_upnp=yes AC_DEFINE([HAS_GUPNP_VERSION_1_2], 1, ["Version is at least 1.2"]), enable_upnp=no)
- PKG_CHECK_MODULES(UPNP, gupnp-1.0 >= $GUPNP_REQUIRED,
+ PKG_CHECK_MODULES(UPNP, gupnp-1.6 >= $GUPNP_REQUIRED,
enable_upnp=yes, enable_upnp=no)
if test "${enable_upnp}" != "yes" ; then
sendto_plugin_error_or_ignore "you need gupnp installed to build the upnp plugin"