summaryrefslogtreecommitdiff
path: root/sendto/plugins/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-03-23 21:17:06 +0100
committerinfirit <[email protected]>2014-03-23 21:29:09 +0100
commit419bf609c5d30cd681979330ac3e8ee995bc7c2e (patch)
treec9c2e3fecf1772ad7ab44909300d0caa9d4e1e73 /sendto/plugins/Makefile.am
parent4a840eab5dec7f2cc8300d50019f52eb2db777b4 (diff)
downloadcaja-extensions-419bf609c5d30cd681979330ac3e8ee995bc7c2e.tar.bz2
caja-extensions-419bf609c5d30cd681979330ac3e8ee995bc7c2e.tar.xz
sendto plugin: re-introduce the option to select plugins to build
Diffstat (limited to 'sendto/plugins/Makefile.am')
-rw-r--r--sendto/plugins/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/sendto/plugins/Makefile.am b/sendto/plugins/Makefile.am
index 10097e8..6d17c98 100644
--- a/sendto/plugins/Makefile.am
+++ b/sendto/plugins/Makefile.am
@@ -1,16 +1,13 @@
-SUBDIRS = . \
- caja-burn \
- emailclient \
- gajim \
- pidgin \
- removable-devices \
- upnp
+SUBDIRS = . $(SENDTO_PLUGINS)
+DIST_SUBDIRS = $(ALL_SENDTO_PLUGINS)
NST_COMMON_SOURCES = nst-common.c nst-common.h
+if HAVE_GIO
noinst_LTLIBRARIES = libnstcommon.la
libnstcommon_la_SOURCES = $(NST_COMMON_SOURCES)
libnstcommon_la_CFLAGS = $(SENDTO_CFLAGS)
libnstcommon_la_LIBADD = $(SENDTO_LIBS)
+endif
EXTRA_DIST = $(NST_COMMON_SOURCES)