summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPablo Barciela <[email protected]>2019-01-13 14:19:03 +0100
committerraveit65 <[email protected]>2019-01-21 10:55:31 +0100
commitf0775c85525994d9beaac87cf71db2813ed61c39 (patch)
tree839879533be6c43ee4607fedd00ced77a2f528fe /configure.ac
parent74081461ea85c62db9954b6a9c35dbeda00aec61 (diff)
downloadcaja-f0775c85525994d9beaac87cf71db2813ed61c39.tar.bz2
caja-f0775c85525994d9beaac87cf71db2813ed61c39.tar.xz
configure.ac: Add check for PKG_CONFIG being set.
based in debian patch by Mike Gabriel <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 17fbe1ff..aeaec266 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,11 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AM_DISABLE_STATIC
AM_PROG_LIBTOOL
-AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+PKG_PROG_PKG_CONFIG
+dnl Give error and exit if we dont have pkgconfig
+if test "x$PKG_CONFIG" = "x"; then
+ AC_MSG_ERROR([you need to have pkgconfig installed!])
+fi
AC_CHECK_LIB(m, floor)