summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-02-06 13:09:16 +0800
committerraveit65 <[email protected]>2019-02-06 10:07:09 +0100
commit91f1dc66b6f56e57734d3048501a6c4679331290 (patch)
treea282106ac4891b9c1705b04ee544ca56f2629f90 /configure.ac
parent2fde826ae189a535bfe00c15ca3ba7c51daaa08b (diff)
downloadcaja-91f1dc66b6f56e57734d3048501a6c4679331290.tar.bz2
caja-91f1dc66b6f56e57734d3048501a6c4679331290.tar.xz
Add --disable-self-check for configure
Fixed make distcheck, see #1129
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94f46a65..027b6cde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,6 +190,17 @@ AC_ARG_ENABLE(empty_view,
AC_SUBST(ENABLE_EMPTY_VIEW)
AM_CONDITIONAL(ENABLE_EMPTY_VIEW, test "x$ENABLE_EMPTY_VIEW" = "x1")
+dnl ========== EEL/CAJA OMIT SELF CHECK ====================================
+AC_ARG_ENABLE(self-check,
+ AC_HELP_STRING([--disable-self-check], [build with self check]))
+msg_self_check=yes
+if test "x$enable_self_check" == "xno"; then
+ msg_self_check=no
+ AC_DEFINE(EEL_OMIT_SELF_CHECK, 1, [define to disable eel self check])
+ AC_DEFINE(CAJA_OMIT_SELF_CHECK, 1, [define to disable caja self check])
+fi
+AM_CONDITIONAL(ENABLE_SELF_CHECK, test "x$msg_self_check" = "xyes")
+
dnl ==========================================================================
AC_ARG_ENABLE(packagekit,
@@ -366,6 +377,7 @@ caja-$VERSION:
compiler: ${CC}
xmp support: $msg_xmp
PackageKit support: $msg_packagekit
+ Self check: $msg_self_check
caja-extension documentation: ${enable_gtk_doc}
caja-extension introspection: ${found_introspection}