summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid H. Gutteridge <[email protected]>2019-03-06 20:12:18 -0500
committerVictor Kareh <[email protected]>2019-03-07 13:49:51 -0500
commit9e5be1fd5bedce65d7f80ce3e44a3c7889b18f40 (patch)
tree1509cb72d14b0c08d60e9e292f57359b231f5bed /configure.ac
parent33adc930ad133b0d169edbf619c3692da47f9c2f (diff)
downloadcaja-9e5be1fd5bedce65d7f80ce3e44a3c7889b18f40.tar.bz2
caja-9e5be1fd5bedce65d7f80ce3e44a3c7889b18f40.tar.xz
configure.ac: fix portability issue with test
"test ... ==" isn't a portable expression, change to POSIX "=".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b2ac7b3c..156027ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,7 @@ dnl ========== EEL/CAJA OMIT SELF CHECK ====================================
AC_ARG_ENABLE(self-check,
AC_HELP_STRING([--disable-self-check], [build without self check]))
msg_self_check=yes
-if test "x$enable_self_check" == "xno"; then
+if test "x$enable_self_check" = "xno"; then
msg_self_check=no
AC_DEFINE(EEL_OMIT_SELF_CHECK, 1, [define to disable eel self check])
AC_DEFINE(CAJA_OMIT_SELF_CHECK, 1, [define to disable caja self check])