summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-04-30 13:12:04 +0200
committerraveit65 <[email protected]>2019-05-04 19:23:16 +0200
commit476f56a25be636970b336d525a7766b6d1eb3fff (patch)
tree44ee464da369bcd56331fe8b1f5e5aa64c535f94 /configure.ac
parent02646f7773b7b9b46df570e06084e428817889f0 (diff)
downloadcaja-476f56a25be636970b336d525a7766b6d1eb3fff.tar.bz2
caja-476f56a25be636970b336d525a7766b6d1eb3fff.tar.xz
eel: remove date & time functions
Do not need to extend glib library, since it now incorporates these functions. Extended date format modifiers are available on glib v2.56. eel-glib-extensions.h/c: GDate * eel_g_date_new_tm (struct tm *time_pieces); char * eel_strdup_strftime (const char *format, struct tm *time_pieces); gint64 eel_get_system_time (void); Do not need to test the extensions in eel_self_check_glib_extensions (void). eel-glib-extensions.c: static void check_tm_to_g_date (time_t time) static char * test_strftime (...) Do not need to check if strftime implements extended date format modifiers on the system (available on glibc v2.27). configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index aa028b67..e7347025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,25 +259,6 @@ fi
AC_SUBST(WARNING_CFLAGS)
-dnl ===========================================================================
-
-dnl strftime checks
-
-AC_TRY_RUN([#include <time.h>
- int main ()
- {
- char buf[100];
- struct tm tm = {0};
- tm.tm_year = 99;
- if (strftime(buf, 100, "%EY", &tm) == 4 &&
- strcmp (buf, "1999")==0)
- return 0;
- return 1;
- }
- ],
- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
-)
-
dnl ==========================================================================
dnl libegg