summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-04-30 13:12:04 +0200
committerraveit65 <[email protected]>2022-07-19 23:40:12 +0200
commit64b7d2640fc91c28db3a16239f8fe5f6243bec26 (patch)
treeb12ae2b4f01c57cd205f4a3ba02b447eb9605296 /configure.ac
parenteb89ab06d009e620e037b7e9ea3a75fc450a0a75 (diff)
downloadcaja-64b7d2640fc91c28db3a16239f8fe5f6243bec26.tar.bz2
caja-64b7d2640fc91c28db3a16239f8fe5f6243bec26.tar.xz
eel: remove date & time functions
Do not need to extend glib library, since it now incorporates these functions. Extended date format modifiers are available on glib v2.56. eel-glib-extensions.h/c: GDate * eel_g_date_new_tm (struct tm *time_pieces); char * eel_strdup_strftime (const char *format, struct tm *time_pieces); gint64 eel_get_system_time (void); Do not need to test the extensions in eel_self_check_glib_extensions (void). eel-glib-extensions.c: static void check_tm_to_g_date (time_t time) static char * test_strftime (...) Do not need to check if strftime implements extended date format modifiers on the system (available on glibc v2.27). configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index b0effbdb..d28bc88c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,25 +259,6 @@ fi
AC_SUBST(WARNING_CFLAGS)
-dnl ===========================================================================
-
-dnl strftime checks
-
-AC_TRY_RUN([#include <time.h>
- int main ()
- {
- char buf[100];
- struct tm tm = {0};
- tm.tm_year = 99;
- if (strftime(buf, 100, "%EY", &tm) == 4 &&
- strcmp (buf, "1999")==0)
- return 0;
- return 1;
- }
- ],
- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
-)
-
dnl ==========================================================================
dnl libegg