summaryrefslogtreecommitdiff
path: root/libegg/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2018-01-12 20:04:25 +0300
committerraveit65 <[email protected]>2018-01-14 15:36:26 +0100
commit6c162ba243f9e62651a13ce2cb4ca2ec9d422509 (patch)
tree6c91f9552d37e05cc413de376f6e8a527bbbfc02 /libegg/Makefile.am
parentf8482dd96bf98d1b14e3f62d3b3a2be44fdc26a4 (diff)
downloadcaja-6c162ba243f9e62651a13ce2cb4ca2ec9d422509.tar.bz2
caja-6c162ba243f9e62651a13ce2cb4ca2ec9d422509.tar.xz
move libegg to the top srcdir and drop some leftovers
Diffstat (limited to 'libegg/Makefile.am')
-rw-r--r--libegg/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/libegg/Makefile.am b/libegg/Makefile.am
new file mode 100644
index 00000000..89e4350a
--- /dev/null
+++ b/libegg/Makefile.am
@@ -0,0 +1,35 @@
+NULL=
+
+noinst_LTLIBRARIES = libegg.la
+
+AM_CPPFLAGS = $(LIBEGG_CFLAGS)
+
+EGG_TREE_DND_FILES = \
+ eggtreemultidnd.c \
+ eggtreemultidnd.h \
+ $(NULL)
+
+EGG_SMCLIENT_FILES = \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ eggsmclient-xsmp.c \
+ $(NULL)
+
+libegg_la_SOURCES = \
+ $(EGG_TREE_DND_FILES) \
+ $(EGG_SMCLIENT_FILES) \
+ $(NULL)
+
+libegg_la_CFLAGS = \
+ -DEGG_SM_CLIENT_BACKEND_XSMP \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ $(LIBEGG_CFLAGS) \
+ $(WARNING_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+libegg_la_LIBADD = \
+ $(LIBEGG_LIBS) \
+ -lSM -lICE