summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38b602c7..26399af1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,6 +440,13 @@ AC_ARG_ENABLE(update-mimedb,
enable_update_mimedb=yes)
AM_CONDITIONAL(ENABLE_UPDATE_MIMEDB, test x$enable_update_mimedb = xyes)
+AC_ARG_ENABLE(icon-update, AC_HELP_STRING([--disable-icon-update],
+ [Disable icon cache update]))
+if (test "$enable_icon_update" != no); then
+ AC_PATH_PROG(UPDATE_ICON_CACHE, [gtk-update-icon-cache])
+fi
+AM_CONDITIONAL([ICON_UPDATE], [test -n "$UPDATE_ICON_CACHE"])
+
AC_CONFIG_FILES([
Makefile
cut-n-paste-code/Makefile