summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c929e6d3..21de26ee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -52,6 +52,11 @@ desktopdir = $(datadir)/mate/network/
schemedir = $(datadir)/applications
scheme_DATA = mate-network-scheme.desktop
+BUILT_SOURCES = \
+ caja-src-marshal.c \
+ caja-src-marshal.h \
+ $(NULL)
+
caja_SOURCES = \
caja-actions.h \
caja-application.c \
@@ -141,6 +146,28 @@ caja_SOURCES = \
caja-zoom-control.h \
$(NULL)
+nodist_caja_SOURCES = \
+ $(BUILT_SOURCES) \
+ $(NULL)
+
+caja-src-marshal.list: $(caja_SOURCES) Makefile.am
+ $(AM_V_GEN)( cd $(srcdir) && \
+ sed -n -e 's/.*caja_src_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
+ $(caja_SOURCES) ) \
+ | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > [email protected]
+ @if cmp -s [email protected] $@; then \
+ else \
+ fi
+
+%-marshal.c: %-marshal.list Makefile
+ $(AM_V_GEN)echo "#include \"caja-src-marshal.h\"" > $@ && \
+ $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
+
+%-marshal.h: %-marshal.list Makefile
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
+
caja_file_management_properties_SOURCES = \
caja-file-management-properties.c \
caja-file-management-properties.h \
@@ -179,19 +206,18 @@ ui_DATA = \
$(NULL)
CLEANFILES = \
+ $(BUILT_SOURCES) \
$(desktop_files) \
$(server_DATA) \
$(NULL)
EXTRA_DIST = \
+ caja-src-marshal.list \
$(server_in_files) \
$(ui_DATA) \
check-caja \
$(desktop_in_files) \
$(NULL)
-BUILT_SOURCES = \
- $(NULL)
-
dist-hook:
cd $(distdir); rm -f $(CLEANFILES)