summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 06bd831d..0f917ea4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,6 +19,7 @@ AM_CPPFLAGS = \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(libdir)"\" \
-DCAJA_DATADIR=\""$(datadir)/caja"\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
-DUIDIR=\""$(datadir)/caja/ui"\" \
-DCAJA_PIXMAPDIR=\""$(datadir)/pixmaps/caja"\" \
-DPREFIX=\""$(prefix)"\" \
@@ -50,12 +51,13 @@ $(dbus_freedesktop_built_sources) : Makefile.am $(top_srcdir)/data/freedesktop-d
$(top_srcdir)/data/freedesktop-dbus-interfaces.xml \
$(NULL)
-@INTLTOOL_DESKTOP_RULE@
-
desktop_in_files=mate-network-scheme.desktop.in
desktop_files=$(desktop_in_files:.desktop.in=.desktop)
desktopdir = $(datadir)/mate/network/
+$(desktop_files): $(desktop_in_files)
+ $(AM_V_GEN) GETTEXTDATADIR=$(top_srcdir) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
schemedir = $(datadir)/applications
scheme_DATA = mate-network-scheme.desktop
@@ -206,8 +208,6 @@ if ENABLE_SELF_CHECK
TESTS=check-caja
endif
-@INTLTOOL_SERVER_RULE@
-
uidir = $(datadir)/caja/ui
ui_DATA = \
caja-shell-ui.xml \