summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-12-16 13:41:24 -0800
committerStefano Karapetsas <[email protected]>2013-12-16 13:41:24 -0800
commit325e6e485a88efeee316f633ae3dfeed1be45ceb (patch)
tree571e8761bed2d20b8f4214de15dd67639b2b4312 /configure.ac
parente681aef8d1f9906515edd649936bca33a2103e73 (diff)
parentf29a02cc3c8cbb50d0e4f1a5220fef27dce9e9ca (diff)
downloadengrampa-325e6e485a88efeee316f633ae3dfeed1be45ceb.tar.bz2
engrampa-325e6e485a88efeee316f633ae3dfeed1be45ceb.tar.xz
Merge pull request #37 from infirit/1.6
Cherrypick usefull commits from master
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9f3eb25..4560d48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,11 +3,12 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
AC_INIT([engrampa], [1.6.0], [http://www.mate-desktop.org/])
-AM_INIT_AUTOMAKE([1.9 foreign])
+AM_INIT_AUTOMAKE([1.9 foreign dist-xz no-dist-gzip])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_SRCDIR([config.h.in])
AC_CONFIG_HEADER([config.h])
+AC_CONFIG_MACRO_DIR([m4])
MATE_COMMON_INIT
@@ -150,8 +151,17 @@ AC_SUBST(DISABLE_DEPRECATED)
dnl ******************************
-CAJA_EXTENSION_DIR=`$PKG_CONFIG --variable=extensiondir libcaja-extension`
-AC_SUBST(CAJA_EXTENSION_DIR)
+AC_ARG_WITH(cajadir,
+ AS_HELP_STRING([--with-cajadir=DIR],[Installation path for Caja extension @<:@auto@:>@]),
+ [ac_with_cajadir=$withval],
+ [ac_with_cajadir=""])
+if test "${ac_with_cajadir}" = ""; then
+ ac_with_cajadir=`pkg-config --variable=extensiondir libcaja-extension`
+fi
+
+AC_MSG_NOTICE([installing caja plugin in ${ac_with_cajadir}])
+AC_SUBST([CAJA_EXTENSION_DIR],[${ac_with_cajadir}])
+
dnl ******************************