summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-06-30 10:24:17 +0200
committerinfirit <[email protected]>2013-06-30 10:24:17 +0200
commitac5d3248257e9e1ddbf57ca5828a1de165d445a4 (patch)
tree1e2bf6455574395b84a2010595d05a13ff100b6b /src/Makefile.am
parentc36eeddc49f116d5d860f2cd13eb94996489f70b (diff)
downloadengrampa-ac5d3248257e9e1ddbf57ca5828a1de165d445a4.tar.bz2
engrampa-ac5d3248257e9e1ddbf57ca5828a1de165d445a4.tar.xz
Add unachiver support
Based on the following commits from file-roller, https://git.gnome.org/browse/file-roller/commit/?id=2575177ac037d2a8d8f3056b10685928d80d6275 https://git.gnome.org/browse/file-roller/commit/?id=f26caa6d5b76d406976ea78630fbaae4c8126a2e
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3fd656b..5722e2d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,8 @@ INCLUDES = \
-DPRIVEXECDIR=\"$(privexecdir)\" \
-DSHDIR=\"$(shdir)\" \
$(DISABLE_DEPRECATED) \
- $(FR_CFLAGS)
+ $(FR_CFLAGS) \
+ $(JSON_GLIB_CFLAGS)
BUILT_SOURCES = \
fr-marshal.c \
@@ -149,6 +150,12 @@ engrampa_SOURCES = \
$(MKDTEMP_FILES) \
$(BUILT_SOURCES)
+if ENABLE_JSON_GLIB
+engrampa_SOURCES += \
+ fr-command-unarchiver.h \
+ fr-command-unarchiver.c
+endif
+
fr-marshal.h: fr-marshal.list $(GLIB_GENMARSHAL)
$(AM_V_GEN)( $(GLIB_GENMARSHAL) $< --header --prefix=fr_marshal > $@ )
@@ -179,7 +186,8 @@ fr-enum-types.c: typedefs.h fr-enum-types.h
engrampa_LDADD = \
$(top_builddir)/copy-n-paste/libeggsmclient.la \
- $(FR_LIBS)
+ $(FR_LIBS) \
+ ${JSON_GLIB_LIBS}
EXTRA_DIST = fr-marshal.list