summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cba14ad..ef11ec3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -189,7 +189,11 @@ fr-enum-types.c: typedefs.h fr-enum-types.h
engrampa_LDADD = \
$(top_builddir)/copy-n-paste/libeggsmclient.la \
$(FR_LIBS) \
- ${JSON_GLIB_LIBS}
+ ${JSON_GLIB_LIBS}
+
+if ENABLE_MAGIC
+engrampa_LDADD += $(MAGIC_LIBS)
+endif
EXTRA_DIST = fr-marshal.list