summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2014-09-23 10:27:30 +0200
committerStefano Karapetsas <[email protected]>2014-09-23 10:27:30 +0200
commit977222daed8436b7486285fce163809c0a489b32 (patch)
tree8710b6b84b548d5cd99d1d36ec46f6a18f0f13ee /data/Makefile.am
parent3ac5d7b70e4a4d8c44b9e9eac4d609e7e5214ff3 (diff)
downloadeom-977222daed8436b7486285fce163809c0a489b32.tar.bz2
eom-977222daed8436b7486285fce163809c0a489b32.tar.xz
Add AppData file
Provided by Richard Hughes <[email protected]> Closes https://github.com/mate-desktop/eom/issues/56
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9c5ca4c..aa96833 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -9,6 +9,10 @@ desktopdir = $(datadir)/applications
desktop_DATA = $(DESKTOP_FILES)
@INTLTOOL_XML_NOMERGE_RULE@
+appdatadir = $(datadir)/appdata
+dist_appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+appdata_in_files = eom.appdata.xml.in
+
gsettings_ENUM_NAMESPACE = org.mate.eom
gsettings_ENUM_FILES = $(top_srcdir)/src/eom-scroll-view.h \
$(top_srcdir)/src/eom-window.h
@@ -43,6 +47,9 @@ EXTRA_DIST = \
$(DESKTOP_IN_FILES) \
$(gsettings_SCHEMAS).in.in
+CLEANFILES = \
+ eom.appdata.xml
+
DISTCLEANFILES = \
$(DESKTOP_FILES) \
$(gsettings_SCHEMAS_in) \