summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-11-30 22:08:37 +0300
committermonsta <[email protected]>2016-11-30 22:35:56 +0300
commitd62da96bdf2aff605fb338b19c2f729dfaca93b4 (patch)
tree3602612e64e77ef10b7b85d887a56618fcb91158 /plugins/Makefile.am
parent5ee13bce9f5c4672d24006be64790bd206b68319 (diff)
downloadeom-d62da96bdf2aff605fb338b19c2f729dfaca93b4.tar.bz2
eom-d62da96bdf2aff605fb338b19c2f729dfaca93b4.tar.xz
plugins: make them actually recognized and loaded by eom
- use *.plugin extension instead of *.eom-plugin - use "Plugin" section name instead of "Eom Plugin" mostly adapted from: https://git.gnome.org/browse/eog/commit/?id=40bedbf33812e65f4a8e79691b1fadfaace94035 https://git.gnome.org/browse/eog/commit/?id=af184104018f36272ff8e49012c52d503f48eae7
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 02b74e6..6398011 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -15,8 +15,8 @@ plugins_LTLIBRARIES = \
reload/libreload.la
plugins_in_files = \
- fullscreen/fullscreen.eom-plugin.desktop.in \
- reload/reload.eom-plugin.desktop.in
+ fullscreen/fullscreen.plugin.desktop.in \
+ reload/reload.plugin.desktop.in
# Fullscreen plugin
fullscreen_libfullscreen_la_SOURCES = \
@@ -41,14 +41,14 @@ statusbar_date_libstatusbar_date_la_SOURCES = \
statusbar-date/eom-statusbar-date-plugin.c
statusbar_date_libstatusbar_date_la_LIBADD = $(EOM_LIBS)
-plugins_in_files += statusbar-date/statusbar-date.eom-plugin.desktop.in
+plugins_in_files += statusbar-date/statusbar-date.plugin.desktop.in
endif
# Generate plugin info files
-%.eom-plugin: %.eom-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(AM_V_GEN)$(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+%.plugin: %.plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(AM_V_GEN)$(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-plugins_DATA = $(plugins_in_files:.eom-plugin.desktop.in=.eom-plugin)
+plugins_DATA = $(plugins_in_files:.plugin.desktop.in=.plugin)
DISTCLEANFILES = $(plugins_DATA)
CLEANFILES = $(plugins_DATA)