summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorClaudio Saavedra <[email protected]>2011-06-09 22:33:30 +0300
committerraveit65 <[email protected]>2018-07-08 12:19:44 +0200
commit20d704b7b4f2560ee27cc9be25359107ceb4a14b (patch)
tree202e9a1335722c7f288019972b4e4afe5ae0f98a /src/Makefile.am
parent63a6313edf251919487047f47ad1f08228e7ba8d (diff)
downloadeom-20d704b7b4f2560ee27cc9be25359107ceb4a14b.tar.bz2
eom-20d704b7b4f2560ee27cc9be25359107ceb4a14b.tar.xz
Port EomApplication to GtkApplication
This removes the direct dependency on dbus and makes use of the GApplication/GtkApplication facilities for uniqueness and activation. Bump the glib requirement to 2.29.4, since we need G_APPLICATION_NON_UNIQUE. https://bugzilla.gnome.org/show_bug.cgi?id=622876 origin commit: https://gitlab.gnome.org/GNOME/eog/commit/3d39587 Enable TotemScreensaver unconditionally It uses GDBus instead of libdbus now. It can be enabled even if libdbus is not available as GDBus/GIO is always present. origin commit: https://gitlab.gnome.org/GNOME/eog/commit/4c32882
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c42c0de..66db511 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -191,17 +191,6 @@ EXTRA_DIST = \
eom-enum-types.c.template \
eom-marshal.list
-if HAVE_DBUS
-
-BUILT_SOURCES += eom-application-service.h
-
-EXTRA_DIST += eom-application-service.xml
-
-eom-application-service.h: eom-application-service.xml
- $(AM_V_GEN)dbus-binding-tool --prefix=eom_application --mode=glib-server --output=eom-application-service.h $<
-
-endif
-
CLEANFILES = $(BUILT_SOURCES)
if HAVE_INTROSPECTION