summaryrefslogtreecommitdiff
path: root/thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-01-28 14:02:06 +0100
committerraveit65 <[email protected]>2020-02-04 23:00:30 +0100
commit43c2d257abf33d402bf6e219a0a5362db7b9ba64 (patch)
treebafaff02b0e3e17803c2ad3c9652c2f46d10411a /thumbnailer/Makefile.am
parentb8914e016c2e5b62f0583aaa742d36e0a3423161 (diff)
downloadeom-43c2d257abf33d402bf6e219a0a5362db7b9ba64.tar.bz2
eom-43c2d257abf33d402bf6e219a0a5362db7b9ba64.tar.xz
thumbnailer: add --with-gdk-pixbuf-thumbnailer option
Let user choose gdk-pixbuf-thumbnailer or eom-thumbnailer for making webp thumbnails.
Diffstat (limited to 'thumbnailer/Makefile.am')
-rw-r--r--thumbnailer/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/thumbnailer/Makefile.am b/thumbnailer/Makefile.am
index 4501ba7..04b56a7 100644
--- a/thumbnailer/Makefile.am
+++ b/thumbnailer/Makefile.am
@@ -1,34 +1,32 @@
NULL =
-bin_PROGRAMS = eom-thumbnailer
+if USE_INTERNAL_THUMBNAILER
+bin_PROGRAMS = eom-thumbnailer
eom_thumbnailer_SOURCES = \
eom-thumbnailer.c \
$(NULL)
-
eom_thumbnailer_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_builddir) \
$(AM_CPPFLAGS) \
$(NULL)
-
eom_thumbnailer_CFLAGS = \
$(THUMBNAILER_CFLAGS) \
$(DISABLE_DEPRECATED) \
$(WARN_CFLAGS) \
$(AM_CFLAGS) \
$(NULL)
-
eom_thumbnailer_LDFLAGS = \
$(AM_LDFLAGS) \
-lm \
$(THUMBNAILER_LIBS) \
$(NULL)
+endif
+
thumbnailerdir = $(datadir)/thumbnailers
thumbnailer_DATA = eom-thumbnailer.thumbnailer
-%.thumbnailer: %.thumbnailer.in
- $(AM_V_GEN) sed -e 's|@bindir[@]|$(bindir)|g' $< > $@
EXTRA_DIST = \
eom-thumbnailer.thumbnailer.in \