summaryrefslogtreecommitdiff
path: root/thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2020-01-21 18:23:05 +0100
committerraveit65 <[email protected]>2020-02-04 23:00:30 +0100
commitb8914e016c2e5b62f0583aaa742d36e0a3423161 (patch)
tree9616d0e08b954a22d16a34f2ca7e2cde9108b574 /thumbnailer/Makefile.am
parentb06fa361183d8f535adf814b2dcb8e878665e44c (diff)
downloadeom-b8914e016c2e5b62f0583aaa742d36e0a3423161.tar.bz2
eom-b8914e016c2e5b62f0583aaa742d36e0a3423161.tar.xz
Add eom-thumbnailer for webp files
Diffstat (limited to 'thumbnailer/Makefile.am')
-rw-r--r--thumbnailer/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/thumbnailer/Makefile.am b/thumbnailer/Makefile.am
new file mode 100644
index 0000000..4501ba7
--- /dev/null
+++ b/thumbnailer/Makefile.am
@@ -0,0 +1,41 @@
+NULL =
+
+bin_PROGRAMS = eom-thumbnailer
+
+eom_thumbnailer_SOURCES = \
+ eom-thumbnailer.c \
+ $(NULL)
+
+eom_thumbnailer_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(AM_CPPFLAGS) \
+ $(NULL)
+
+eom_thumbnailer_CFLAGS = \
+ $(THUMBNAILER_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS) \
+ $(AM_CFLAGS) \
+ $(NULL)
+
+eom_thumbnailer_LDFLAGS = \
+ $(AM_LDFLAGS) \
+ -lm \
+ $(THUMBNAILER_LIBS) \
+ $(NULL)
+
+thumbnailerdir = $(datadir)/thumbnailers
+thumbnailer_DATA = eom-thumbnailer.thumbnailer
+%.thumbnailer: %.thumbnailer.in
+ $(AM_V_GEN) sed -e 's|@bindir[@]|$(bindir)|g' $< > $@
+
+EXTRA_DIST = \
+ eom-thumbnailer.thumbnailer.in \
+ $(NULL)
+
+CLEANFILES = \
+ $(thumbnailer_DATA) \
+ $(NULL)
+
+-include $(top_srcdir)/git.mk