summaryrefslogtreecommitdiff
path: root/backends/oss/Makefile.am
diff options
context:
space:
mode:
authorMichal Ratajsky <[email protected]>2014-07-18 16:51:07 +0200
committerMichal Ratajsky <[email protected]>2014-07-18 16:51:07 +0200
commit0bc3aa762cd794da510f03229840d939ee7bc0c9 (patch)
tree889ec2ae5954a45ea68c3166cbab6bbe16c342cb /backends/oss/Makefile.am
parent1c842063e1f7bf6803655ac193ac28704c4dc0c2 (diff)
downloadlibmatemixer-0bc3aa762cd794da510f03229840d939ee7bc0c9.tar.bz2
libmatemixer-0bc3aa762cd794da510f03229840d939ee7bc0c9.tar.xz
Add module skeleton and build support
Diffstat (limited to 'backends/oss/Makefile.am')
-rw-r--r--backends/oss/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/backends/oss/Makefile.am b/backends/oss/Makefile.am
new file mode 100644
index 0000000..3f0b8ea
--- /dev/null
+++ b/backends/oss/Makefile.am
@@ -0,0 +1,26 @@
+backenddir = $(libdir)/libmatemixer
+
+backend_LTLIBRARIES = libmatemixer-oss.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"libmatemixer-oss\"
+
+libmatemixer_oss_la_CFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(OSS_CFLAGS)
+
+libmatemixer_oss_la_SOURCES = \
+ oss-backend.c \
+ oss-backend.h
+
+libmatemixer_oss_la_LIBADD = \
+ $(GLIB_LIBS)
+
+libmatemixer_oss_la_LDFLAGS = \
+ -avoid-version \
+ -no-undefined \
+ -export-dynamic \
+ -module
+
+-include $(top_srcdir)/git.mk