summaryrefslogtreecommitdiff
path: root/backends/oss4/Makefile.am
diff options
context:
space:
mode:
authorMichal Ratajsky <[email protected]>2014-07-27 13:12:53 +0200
committerMichal Ratajsky <[email protected]>2014-07-27 13:12:53 +0200
commit8436ec1641eee8868128755f6d1475230cea25e6 (patch)
tree1883410069b08ad7068ee1fc52df3fadb60d7bd3 /backends/oss4/Makefile.am
parente369a047e3a43bd149fbce0af475bdef853aaf1a (diff)
downloadlibmatemixer-8436ec1641eee8868128755f6d1475230cea25e6.tar.bz2
libmatemixer-8436ec1641eee8868128755f6d1475230cea25e6.tar.xz
Beginning of OSS4 support
Diffstat (limited to 'backends/oss4/Makefile.am')
-rw-r--r--backends/oss4/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/backends/oss4/Makefile.am b/backends/oss4/Makefile.am
new file mode 100644
index 0000000..cca8723
--- /dev/null
+++ b/backends/oss4/Makefile.am
@@ -0,0 +1,29 @@
+backenddir = $(libdir)/libmatemixer
+
+backend_LTLIBRARIES = libmatemixer-oss4.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"libmatemixer-oss4\"
+
+libmatemixer_oss4_la_CFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(OSS4_CFLAGS)
+
+libmatemixer_oss4_la_SOURCES = \
+ oss4-common.h \
+ oss4-backend.c \
+ oss4-backend.h \
+ oss4-device.c \
+ oss4-device.h
+
+libmatemixer_oss4_la_LIBADD = \
+ $(GLIB_LIBS)
+
+libmatemixer_oss4_la_LDFLAGS = \
+ -avoid-version \
+ -no-undefined \
+ -export-dynamic \
+ -module
+
+-include $(top_srcdir)/git.mk