summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Ratajsky <[email protected]>2014-08-12 05:20:22 +0200
committerMichal Ratajsky <[email protected]>2014-08-12 05:20:22 +0200
commit94d24482d8b1013947c0e2dac7330180b6ae02f6 (patch)
treeb819cb858e5ad7903f18db6118e6d78cc843c2e9 /configure.ac
parent006ea9dd9baa9e879fc9ab47626e3e38d1aac634 (diff)
downloadlibmatemixer-94d24482d8b1013947c0e2dac7330180b6ae02f6.tar.bz2
libmatemixer-94d24482d8b1013947c0e2dac7330180b6ae02f6.tar.xz
Fix for configure output
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d376b19..d3c2173 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,9 @@ GTK_DOC_CHECK([1.10], [--flavour no-tmpl])
# =======================================================================
# Check for backend module support
# =======================================================================
+# -----------------------------------------------------------------------
+# Null
+# -----------------------------------------------------------------------
AC_ARG_ENABLE([null],
AS_HELP_STRING([--enable-null],
[Enable Null backend module @<:@default=yes@:>@]),
@@ -89,6 +92,9 @@ fi
AM_CONDITIONAL(HAVE_NULL, test "x$have_null" = "xyes")
AC_SUBST(HAVE_NULL)
+# -----------------------------------------------------------------------
+# PulseAudio
+# -----------------------------------------------------------------------
PA_REQUIRED_VERSION=0.9.23
AC_ARG_ENABLE([pulseaudio],
@@ -110,6 +116,8 @@ if test "x$enable_pulseaudio" != "xno"; then
if test "x$have_pulseaudio" = "xyes" ; then
AC_DEFINE(HAVE_PULSEAUDIO, [], [Define if we have PulseAudio support])
fi
+else
+ have_pulseaudio=no
fi
AM_CONDITIONAL(HAVE_PULSEAUDIO, test "x$have_pulseaudio" = "xyes")
@@ -143,6 +151,8 @@ if test "x$enable_alsa" != "xno"; then
if test "x$have_alsa" = "xyes" ; then
AC_DEFINE(HAVE_ALSA, [], [Define if we have ALSA support])
fi
+else
+ have_alsa=no
fi
AM_CONDITIONAL(HAVE_ALSA, test "x$have_alsa" = "xyes")