summaryrefslogtreecommitdiff
path: root/backends/null/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backends/null/Makefile.am')
-rw-r--r--backends/null/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/backends/null/Makefile.am b/backends/null/Makefile.am
new file mode 100644
index 0000000..b6d92c7
--- /dev/null
+++ b/backends/null/Makefile.am
@@ -0,0 +1,24 @@
+backenddir = $(libdir)/libmatemixer
+
+backend_LTLIBRARIES = libmatemixer-null.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"libmatemixer-null\"
+
+libmatemixer_null_la_CFLAGS = \
+ $(GLIB_CFLAGS)
+
+libmatemixer_null_la_SOURCES = \
+ null.c \
+ null.h
+
+libmatemixer_null_la_LIBADD = \
+ $(GLIB_LIBS)
+
+libmatemixer_null_la_LDFLAGS = \
+ -avoid-version \
+ -export-dynamic \
+ -module
+
+-include $(top_srcdir)/git.mk