summaryrefslogtreecommitdiff
path: root/backends/pulse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backends/pulse/Makefile.am')
-rw-r--r--backends/pulse/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/backends/pulse/Makefile.am b/backends/pulse/Makefile.am
new file mode 100644
index 0000000..2f7cd6f
--- /dev/null
+++ b/backends/pulse/Makefile.am
@@ -0,0 +1,30 @@
+backenddir = $(libdir)/libmatemixer
+
+backend_LTLIBRARIES = libmatemixer-pulse.la
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"libmatemixer-pulse\"
+
+libmatemixer_pulse_la_CFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(PULSEAUDIO_CFLAGS)
+
+libmatemixer_pulse_la_SOURCES = \
+ pulse.c \
+ pulse.h \
+ pulse-device.c \
+ pulse-device.h \
+ pulse-track.c \
+ pulse-track.h
+
+libmatemixer_pulse_la_LIBADD = \
+ $(GLIB_LIBS) \
+ $(PULSEAUDIO_LIBS)
+
+libmatemixer_pulse_la_LDFLAGS = \
+ -avoid-version \
+ -export-dynamic \
+ -module
+
+-include $(top_srcdir)/git.mk